/usr/bin/ldapdelete: invalid option -- '-' ldapdelete: unrecognized option -- Delete entries from an LDAP server usage: ldapdelete [options] [dn]... dn: list of DNs to delete. If not given, it will be read from stdin or from the file specified with "-f file". Delete Options: -c continuous operation mode (do not stop on errors) -f file read operations from `file' -M enable Manage DSA IT control (-MM to make critical) -P version protocol version (default: 3) -r delete recursively Common options: -d level set LDAP debugging level to `level' -D binddn bind DN -e [!][=] general extensions (! indicates criticality) [!]assert= (RFC 4528; a RFC 4515 Filter string) [!]authzid= (RFC 4370; "dn:" or "u:") [!]bauthzid (RFC 3829) [!]chaining[=[/]] one of "chainingPreferred", "chainingRequired", "referralsPreferred", "referralsRequired" [!]manageDSAit (RFC 3296) [!]noop ppolicy [!]postread[=] (RFC 4527; comma-separated attr list) [!]preread[=] (RFC 4527; comma-separated attr list) [!]relax [!]sessiontracking[=] abandon, cancel, ignore (SIGINT sends abandon/cancel, or ignores response; if critical, doesn't wait for SIGINT. not really controls) -H URI LDAP Uniform Resource Identifier(s) -I use SASL Interactive mode -n show what would be done but don't actually do it -N do not use reverse DNS to canonicalize SASL host name -O props SASL security properties -o [=] any libldap ldap.conf options, plus ldif_wrap= (in columns, or "no" for no wrapping) nettimeout= (in seconds, or "none" or "max") -Q use SASL Quiet mode -R realm SASL realm -U authcid SASL authentication identity -v run in verbose mode (diagnostics to standard output) -V print version info (-VV only) -w passwd bind password (for simple authentication) -W prompt for bind password -x Simple authentication -X authzid SASL authorization identity ("dn:" or "u:") -y file Read password from file -Y mech SASL mechanism -Z Start TLS request (-ZZ to require successful response)