/usr/bin/ldapvc: invalid option -- '-' ldapvc: unrecognized option -- Issue LDAP Verify Credentials operation to verify a user's credentials usage: ldapvc [options] [DN [cred]]) where: DN Distinguished Name cred Credentials (prompt if not present) options: -a Request AuthzId -b Request Password Policy Information -E sasl=(a[utomatic]|i[nteractive]|q[uiet]> SASL mode (defaults to automatic if any other -E option provided, otherwise none)) -E mech= SASL mechanism (default e.g. Simple) -E realm= SASL Realm (defaults to none) -E authcid= SASL Authentication Identity (defaults to USER) -E authzid= SASL Authorization Identity (defaults to none) -E secprops= SASL Security Properties (defaults to none) Common options: -d level set LDAP debugging level to `level' -D binddn bind DN -e [!][=] general extensions (! indicates criticality) [!]assert= (RFC 4528; a RFC 4515 Filter string) [!]authzid= (RFC 4370; "dn:" or "u:") [!]bauthzid (RFC 3829) [!]chaining[=[/]] one of "chainingPreferred", "chainingRequired", "referralsPreferred", "referralsRequired" [!]manageDSAit (RFC 3296) [!]noop ppolicy [!]postread[=] (RFC 4527; comma-separated attr list) [!]preread[=] (RFC 4527; comma-separated attr list) [!]relax [!]sessiontracking[=] abandon, cancel, ignore (SIGINT sends abandon/cancel, or ignores response; if critical, doesn't wait for SIGINT. not really controls) -H URI LDAP Uniform Resource Identifier(s) -I use SASL Interactive mode -n show what would be done but don't actually do it -N do not use reverse DNS to canonicalize SASL host name -O props SASL security properties -o [=] any libldap ldap.conf options, plus ldif_wrap= (in columns, or "no" for no wrapping) nettimeout= (in seconds, or "none" or "max") -Q use SASL Quiet mode -R realm SASL realm -U authcid SASL authentication identity -v run in verbose mode (diagnostics to standard output) -V print version info (-VV only) -w passwd bind password (for simple authentication) -W prompt for bind password -x Simple authentication -X authzid SASL authorization identity ("dn:" or "u:") -y file Read password from file -Y mech SASL mechanism -Z Start TLS request (-ZZ to require successful response)