CURLOPT\_TFTP\_NO\_OPTIONS(3) Library Functions Manual CURLOPT\_TFTP\_NO\_OPTIONS(3)

# [NAME](#NAME)

CURLOPT\_TFTP\_NO\_OPTIONS - send no TFTP options requests

# [SYNOPSIS](#SYNOPSIS)

```
#include <curl/curl.h>
CURLcode curl_easy_setopt(CURL *handle, CURLOPT_TFTP_NO_OPTIONS, long onoff);
```

# [DESCRIPTION](#DESCRIPTION)

Set *onoff* to 1L to exclude all TFTP options defined in RFC 2347, RFC 2348 and RFC 2349 from read and write requests.

This option improves interoperability with legacy servers that do not acknowledge or properly implement TFTP options. When this option is used [*CURLOPT\_TFTP\_BLKSIZE(3)*](/man/os/curl/CURLOPT_TFTP_BLKSIZE.3) is ignored.

# [DEFAULT](#DEFAULT)

0

# [PROTOCOLS](#PROTOCOLS)

This functionality affects tftp only

# [EXAMPLE](#EXAMPLE)

```
static size_t write_callback(char *ptr, size_t size, size_t nmemb, void *fp)
{


  return fwrite(ptr, size, nmemb, (FILE *)fp);
}
int main(void)
{


  CURL *curl = curl_easy_init();


  if(curl) {


    CURLcode result = CURLE_OK;


    FILE *fp = fopen("foo.bin", "wb");


    if(fp) {


      curl_easy_setopt(curl, CURLOPT_WRITEDATA, (void *)fp);


      curl_easy_setopt(curl, CURLOPT_WRITEFUNCTION, write_callback);


      curl_easy_setopt(curl, CURLOPT_URL, "tftp://example.com/foo.bin");


      /* do not send TFTP options requests */


      curl_easy_setopt(curl, CURLOPT_TFTP_NO_OPTIONS, 1L);


      /* Perform the request */


      result = curl_easy_perform(curl);


      fclose(fp);


    }


    curl_easy_cleanup(curl);


  }
}
```

# [AVAILABILITY](#AVAILABILITY)

Added in curl 7.48.0

# [RETURN VALUE](#RETURN_VALUE)

[*curl\_easy\_setopt(3)*](/man/os/curl/curl_easy_setopt.3) returns a CURLcode indicating success or error.

CURLE\_OK (0) means everything was OK, non-zero means an error occurred, see [*libcurl-errors(3)*](/man/os/curl/libcurl-errors.3).

# [SEE ALSO](#SEE_ALSO)

[**CURLOPT\_TFTP\_BLKSIZE**(3)](/man/os/curl/CURLOPT_TFTP_BLKSIZE.3)

2026-09-24 libcurl

---

Document: CURLOPT_TFTP_NO_OPTIONS(3) from curl 8.22.0-r3 (Chainguard OS)
Source: https://github.com/curl/curl.git
