ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_b32\_ntop\_calculate\_size, ldns\_b32\_pton\_calculate\_size, ldns\_b64\_ntop\_calculate\_size, ldns\_b64\_pton\_calculate\_size - return size needed for b32 or b64 encoded or decoded data

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

size\_t ldns\_b32\_ntop\_calculate\_size(size\_t src\_data\_length);

size\_t ldns\_b32\_pton\_calculate\_size(size\_t src\_text\_length);

static inline size\_t ldns\_b64\_ntop\_calculate\_size(size\_t srcsize){ return ((((srcsize + 2) / 3) * 4) + 1);

static inline size\_t ldns\_b64\_pton\_calculate\_size(size\_t srcsize){ return (((((srcsize + 3) / 4) * 3)) + 1);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_b32\_ntop\_calculate\_size*() calculates the size needed to store the result of b32\_ntop

*ldns\_b32\_pton\_calculate\_size*() calculates the size needed to store the result of b32\_pton

*ldns\_b64\_ntop\_calculate\_size*() calculates the size needed to store the result of b64\_ntop

*ldns\_b64\_pton\_calculate\_size*() calculates the size needed to store the result of ldns\_b64\_pton

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_b32_pton_calculate_size(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
