ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dname\_is\_subdomain, ldns\_dname\_str\_absolute, ldns\_dname\_label - check properties of dnames

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

bool ldns\_dname\_is\_subdomain(const ldns\_rdf \*sub, const ldns\_rdf \*parent);

bool ldns\_dname\_str\_absolute(const char \*dname\_str);

ldns\_rdf * ldns\_dname\_label(const ldns\_rdf \*rdf, uint8\_t labelpos);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dname\_is\_subdomain*() test whether the name sub falls under parent (i.e. is a subdomain of parent). This function will return false if the given dnames are equal.  
**sub**: the name to test  
**parent**: the parent's name  
Returns true if sub falls under parent, otherwise false

*ldns\_dname\_str\_absolute*() Checks whether the given dname string is absolute (i.e. ends with a '.')  
**\*dname\_str**: a string representing the dname  
Returns true or false

*ldns\_dname\_label*() look inside the rdf and if it is an LDNS\_RDF\_TYPE\_DNAME try and retrieve a specific label. The labels are numbered starting from 0 (left most).  
**rdf**: the rdf to look in  
**labelpos**: return the label with this number  
Returns a ldns\_rdf* with the label as name or NULL on error

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dname_str_absolute(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
