ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dnssec\_rrs\_new, ldns\_dnssec\_rrs\_free, ldns\_dnssec\_rrs\_add\_rr, ldns\_dnssec\_rrs\_print - functions for ldns\_dnssecrrs

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_dnssec\_rrs\_new();

void ldns\_dnssec\_rrs\_free(ldns\_dnssec\_rrs \*rrs);

ldns\_status ldns\_dnssec\_rrs\_add\_rr(ldns\_dnssec\_rrs \*rrs, ldns\_rr \*rr);

void ldns\_dnssec\_rrs\_print(FILE \*out, const ldns\_dnssec\_rrs \*rrs);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dnssec\_rrs\_new*()

*ldns\_dnssec\_rrs\_free*() Frees the list of rrs, but \*not* the individual ldns\_rr records contained in the list

**rrs**: the data structure to free

*ldns\_dnssec\_rrs\_add\_rr*() Adds an RR to the list of RRs. The list will remain ordered. If an equal RR already exists, this RR will not be added.

**rrs**: the list to add to  
**rr**: the RR to add  
Returns LDNS\_STATUS\_OK on success and LDNS\_STATUS\_EQUAL\_ERR when and RR with equal ownername, class, type and rdata already exists.

*ldns\_dnssec\_rrs\_print*() Prints the given rrs to the file descriptor

**out**: the file descriptor to print to  
**rrs**: the list of RRs to print

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_dnssec\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dnssec_rrs_free(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
