ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_fget\_token, ldns\_fskipcs - get tokens from files

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ssize\_t ldns\_fget\_token(FILE \*f, char \*token, const char \*delim, size\_t limit);

void ldns\_fskipcs(FILE \*fp, const char \*s);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_fget\_token*() returns a token/char from the stream F. This function deals with ( and ) in the stream, and ignores them when encountered  
**\*f**: the file to read from  
**\*token**: the read token is put here  
**\*delim**: chars at which the parsing should stop  
**\*limit**: how much to read. If 0 the builtin maximum is used  
Returns 0 on error of EOF of the stream F. Otherwise return the length of what is read

*ldns\_fskipcs*() skips all of the characters in the given string in the fp, moving the position to the first character that is not in \*s.  
**\*fp**: file to use  
**\*s**: characters to skip  
Returns void

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_fskipcs(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
