ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_get\_rr\_class\_by\_name, ldns\_get\_rr\_type\_by\_name - lookup class or type by name

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr\_class ldns\_get\_rr\_class\_by\_name(const char \*name);

ldns\_rr\_type ldns\_get\_rr\_type\_by\_name(const char \*name);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_get\_rr\_class\_by\_name*() retrieves a class by looking up its name.  
**name**: string with the name  
Returns the cass which corresponds with the name

*ldns\_get\_rr\_type\_by\_name*() retrieves a rrtype by looking up its name.  
**name**: a string with the name  
Returns the type which corresponds with the name

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_get_rr_class_by_name(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
