ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_get\_rr\_list\_addr\_by\_name, ldns\_get\_rr\_list\_name\_by\_addr - get addresses by name or names by address

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr\_list* ldns\_get\_rr\_list\_addr\_by\_name(ldns\_resolver \*r, const ldns\_rdf \*name, ldns\_rr\_class c, uint16\_t flags);

ldns\_rr\_list* ldns\_get\_rr\_list\_name\_by\_addr(ldns\_resolver \*r, const ldns\_rdf \*addr, ldns\_rr\_class c, uint16\_t flags);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_get\_rr\_list\_addr\_by\_name*() Ask the resolver about name and return all address records  
**r**: the resolver to use  
**name**: the name to look for  
**c**: the class to use  
**flags**: give some optional flags to the query

*ldns\_get\_rr\_list\_name\_by\_addr*() ask the resolver about the address and return the name  
**r**: the resolver to use  
**addr**: the addr to look for  
**c**: the class to use  
**flags**: give some optional flags to the query

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr\_list*, *ldns\_rr*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_get_rr_list_name_by_addr(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
