ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_key2rr - convert ldns\_key to rr

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr* ldns\_key2rr(const ldns\_key \*k);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_key2rr*() converts a ldns\_key to a public key rr If the key data exists at an external point, the corresponding rdata field must still be added with ldns\_rr\_rdf\_push() to the result rr of this function

**k**: the ldns\_key to convert  
Returns ldns\_rr representation of the key

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_key2rr(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
