ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_key\_free, ldns\_key\_deep\_free, ldns\_key\_list\_free - free a ldns\_key

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

void ldns\_key\_free(ldns\_key \*key);

void ldns\_key\_deep\_free(ldns\_key \*key);

void ldns\_key\_list\_free(ldns\_key\_list \*key\_list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_key\_free*() frees a key structure, but not its internal data structures

**key**: the key object to free

*ldns\_key\_deep\_free*() frees a key structure and all its internal data structures, except the data set by ldns\_key\_set\_external\_key()

**key**: the key object to free

*ldns\_key\_list\_free*() Frees a key list structure  
**key\_list**: the key list object to free

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_key_free(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
