ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_key\_list\_push\_key, ldns\_key\_list\_pop\_key - manipulate ldns\_key\_list

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

bool ldns\_key\_list\_push\_key(ldns\_key\_list \*key\_list, ldns\_key \*key);

ldns\_key* ldns\_key\_list\_pop\_key(ldns\_key\_list \*key\_list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_key\_list\_push\_key*() pushes a key to a keylist  
**key\_list**: the key\_list to push to  
**key**: the key to push  
Returns false on error, otherwise true

*ldns\_key\_list\_pop\_key*() pops the last rr from a keylist  
**key\_list**: the rr\_list to pop from  
Returns NULL if nothing to pop. Otherwise the popped RR

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_key_list_pop_key(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
