ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_key\_rr2ds - create DS rr from DNSKEY rr

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr* ldns\_key\_rr2ds(const ldns\_rr \*key, ldns\_hash h);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_key\_rr2ds*() returns a new DS rr that represents the given key rr.

**\*key**: the key to convert  
**h**: the hash to use LDNS\_SHA1/LDNS\_SHA256

Returns ldns\_rr* a new rr pointer to a DS

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_key_rr2ds(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
