ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_pkt\_verify - verify a packet

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_pkt\_verify(const ldns\_pkt \*p, ldns\_rr\_type t, const ldns\_rdf \*o, const ldns\_rr\_list \*k, const ldns\_rr\_list \*s, ldns\_rr\_list \*good\_keys);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_pkt\_verify*() verify a packet  
**p**: the packet  
**t**: the rr set type to check  
**o**: the rr set name to check  
**k**: list of keys  
**s**: list of sigs (may be null)  
**good\_keys**: keys which validated the packet  
Returns status

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_verify*, *ldns\_sign\_public*, *ldns\_zone\_sign*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_pkt_verify(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
