ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rdf2buffer\_str\_a, ldns\_rdf2buffer\_str\_aaaa, ldns\_rdf2buffer\_str\_str, ldns\_rdf2buffer\_str\_b64, ldns\_rdf2buffer\_str\_hex, ldns\_rdf2buffer\_str\_type, ldns\_rdf2buffer\_str\_class, ldns\_rdf2buffer\_str\_alg, ldns\_rdf2buffer\_str\_loc, ldns\_rdf2buffer\_str\_unknown, ldns\_rdf2buffer\_str\_nsap, ldns\_rdf2buffer\_str\_wks, ldns\_rdf2buffer\_str\_nsec, ldns\_rdf2buffer\_str\_period, ldns\_rdf2buffer\_str\_tsigtime, ldns\_rdf2buffer\_str\_apl, ldns\_rdf2buffer\_str\_int16\_data, ldns\_rdf2buffer\_str\_int16, ldns\_rdf2buffer\_str\_ipseckey - lower level to string conversion functions

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_rdf2buffer\_str\_a(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_aaaa(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_str(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_b64(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_hex(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_type(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_class(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_alg(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_loc(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_unknown(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_nsap(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_wks(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_nsec(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_period(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_tsigtime(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_apl(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_int16\_data(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_int16(ldns\_buffer \*output, const ldns\_rdf \*rdf);

ldns\_status ldns\_rdf2buffer\_str\_ipseckey(ldns\_buffer \*output, const ldns\_rdf \*rdf);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rdf2buffer\_str\_a*() Converts an LDNS\_RDF\_TYPE\_A rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_aaaa*() Converts an LDNS\_RDF\_TYPE\_AAAA rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_str*() Converts an LDNS\_RDF\_TYPE\_STR rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_b64*() Converts an LDNS\_RDF\_TYPE\_B64 rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_hex*() Converts an LDNS\_RDF\_TYPE\_HEX rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_type*() Converts an LDNS\_RDF\_TYPE\_TYPE rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_class*() Converts an LDNS\_RDF\_TYPE\_CLASS rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_alg*() Converts an LDNS\_RDF\_TYPE\_ALG rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_loc*() Converts an LDNS\_RDF\_TYPE\_LOC rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_unknown*() Converts an LDNS\_RDF\_TYPE\_UNKNOWN rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_nsap*() Converts an LDNS\_RDF\_TYPE\_NSAP rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_wks*() Converts an LDNS\_RDF\_TYPE\_WKS rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_nsec*() Converts an LDNS\_RDF\_TYPE\_NSEC rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_period*() Converts an LDNS\_RDF\_TYPE\_PERIOD rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_tsigtime*() Converts an LDNS\_RDF\_TYPE\_TSIGTIME rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_apl*() Converts an LDNS\_RDF\_TYPE\_APL rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_int16\_data*() Converts an LDNS\_RDF\_TYPE\_INT16\_DATA rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_int16*() Converts an LDNS\_RDF\_TYPE\_INT16 rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

*ldns\_rdf2buffer\_str\_ipseckey*() Converts an LDNS\_RDF\_TYPE\_IPSECKEY rdata element to string format and adds it to the output buffer  
**\*rdf**: The rdata to convert  
**\*output**: The buffer to add the data to  
Returns LDNS\_STATUS\_OK on success, and error status on failure

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rdf2buffer_str_a(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
