ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rdf\_size, ldns\_rdf\_get\_type, ldns\_rdf\_data, ldns\_rdf\_compare - get rdf attributes

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

size\_t ldns\_rdf\_size(const ldns\_rdf \*rd);

ldns\_rdf\_type ldns\_rdf\_get\_type(const ldns\_rdf \*rd);

uint8\_t* ldns\_rdf\_data(const ldns\_rdf \*rd);

int ldns\_rdf\_compare(const ldns\_rdf \*rd1, const ldns\_rdf \*rd2);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rdf\_size*() returns the size of the rdf.  
**\*rd**: the rdf to read from  
Returns uint16\_t with the size

*ldns\_rdf\_get\_type*() returns the type of the rdf. We need to insert \_get_ here to prevent conflict the rdf\_type TYPE.  
**\*rd**: the rdf to read from  
Returns ldns\_rdf\_type with the type

*ldns\_rdf\_data*() returns the data of the rdf.  
**\*rd**: the rdf to read from

Returns uint8\_t* pointer to the rdf's data

*ldns\_rdf\_compare*() compares two rdf's on their wire formats. (To order dnames according to rfc4034, use ldns\_dname\_compare)  
**rd1**: the first one  
**rd2**: the second one  
Returns 0 if equal  
Returns -1 if rd1 comes before rd2  
Returns +1 if rd2 comes before rd1

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rdf_get_type(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
