ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_dnskey\_flags, ldns\_rr\_dnskey\_set\_flags, ldns\_rr\_dnskey\_protocol, ldns\_rr\_dnskey\_set\_protocol, ldns\_rr\_dnskey\_algorithm, ldns\_rr\_dnskey\_set\_algorithm, ldns\_rr\_dnskey\_key, ldns\_rr\_dnskey\_set\_key - get and set DNSKEY RR rdata fields

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rdf* ldns\_rr\_dnskey\_flags(const ldns\_rr \*r);

bool ldns\_rr\_dnskey\_set\_flags(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf* ldns\_rr\_dnskey\_protocol(const ldns\_rr \*r);

bool ldns\_rr\_dnskey\_set\_protocol(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf* ldns\_rr\_dnskey\_algorithm(const ldns\_rr \*r);

bool ldns\_rr\_dnskey\_set\_algorithm(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf* ldns\_rr\_dnskey\_key(const ldns\_rr \*r);

bool ldns\_rr\_dnskey\_set\_key(ldns\_rr \*r, ldns\_rdf \*f);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_dnskey\_flags*() returns the flags of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the resource record  
Returns a ldns\_rdf* with the flags or NULL on failure

*ldns\_rr\_dnskey\_set\_flags*() sets the flags of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the rr to use  
**f**: the flags to set  
Returns true on success, false otherwise

*ldns\_rr\_dnskey\_protocol*() returns the protocol of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the resource record  
Returns a ldns\_rdf* with the protocol or NULL on failure

*ldns\_rr\_dnskey\_set\_protocol*() sets the protocol of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the rr to use  
**f**: the protocol to set  
Returns true on success, false otherwise

*ldns\_rr\_dnskey\_algorithm*() returns the algorithm of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the resource record  
Returns a ldns\_rdf* with the algorithm or NULL on failure

*ldns\_rr\_dnskey\_set\_algorithm*() sets the algorithm of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the rr to use  
**f**: the algorithm to set  
Returns true on success, false otherwise

*ldns\_rr\_dnskey\_key*() returns the key data of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the resource record  
Returns a ldns\_rdf* with the key data or NULL on failure

*ldns\_rr\_dnskey\_set\_key*() sets the key data of a LDNS\_RR\_TYPE\_DNSKEY rr  
**r**: the rr to use  
**f**: the key data to set  
Returns true on success, false otherwise

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_dnskey_protocol(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
