ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_list\_cat, ldns\_rr\_list\_push\_rr, ldns\_rr\_list\_pop\_rr - ldns\_rr\_list manipulation

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

bool ldns\_rr\_list\_cat(ldns\_rr\_list \*left, const ldns\_rr\_list \*right);

bool ldns\_rr\_list\_push\_rr(ldns\_rr\_list \*rr\_list, const ldns\_rr \*rr);

ldns\_rr* ldns\_rr\_list\_pop\_rr(ldns\_rr\_list \*rr\_list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_list\_cat*() concatenates two ldns\_rr\_lists together. This modifies \*left (to extend it and add the pointers from \*right).  
**left**: the leftside  
**right**: the rightside  
Returns a left with right concatenated to it

*ldns\_rr\_list\_push\_rr*() pushes an rr to an rrlist.  
**rr\_list**: the rr\_list to push to  
**rr**: the rr to push  
Returns false on error, otherwise true

*ldns\_rr\_list\_pop\_rr*() pops the last rr from an rrlist.  
**rr\_list**: the rr\_list to pop from  
Returns NULL if nothing to pop. Otherwise the popped RR

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_list_cat(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
