ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_list\_new, ldns\_rr\_list\_free - ldns\_rr\_list creation and destruction

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr\_list* ldns\_rr\_list\_new(void);

void ldns\_rr\_list\_free(ldns\_rr\_list \*rr\_list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_list\_new*() creates a new rr\_list structure.  
Returns a new rr\_list structure

*ldns\_rr\_list\_free*() frees an rr\_list structure.  
**rr\_list**: the list to free

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_list_new(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
