ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_list\_rr\_count, ldns\_rr\_list\_set\_rr\_count - get and set ldns\_rr\_list length

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

size\_t ldns\_rr\_list\_rr\_count(const ldns\_rr\_list \*rr\_list);

void ldns\_rr\_list\_set\_rr\_count(ldns\_rr\_list \*rr\_list, size\_t count);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_list\_rr\_count*() returns the number of rr's in an rr\_list.  
**rr\_list**: the rr\_list to read from  
Returns the number of rr's

*ldns\_rr\_list\_set\_rr\_count*() sets the number of rr's in an rr\_list.  
**rr\_list**: the rr\_list to set the count on  
**count**: the number of rr in this list  
Returns void

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_list_set_rr_count(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
