ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_rdf, ldns\_rr\_owner, ldns\_rr\_rd\_count, ldns\_rr\_ttl, ldns\_rr\_get\_class - access rdata fields on ldns\_rr

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rdf* ldns\_rr\_rdf(const ldns\_rr \*rr, size\_t nr);

ldns\_rdf* ldns\_rr\_owner(const ldns\_rr \*rr);

size\_t ldns\_rr\_rd\_count(const ldns\_rr \*rr);

uint32\_t ldns\_rr\_ttl(const ldns\_rr \*rr);

ldns\_rr\_class ldns\_rr\_get\_class(const ldns\_rr \*rr);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_rdf*() returns the rdata field member counter.  
**\*rr**: rr to operate on  
**nr**: the number of the rdf to return  
Returns ldns\_rdf *

*ldns\_rr\_owner*() returns the owner name of an rr structure.  
**\*rr**: rr to operate on  
Returns ldns\_rdf *

*ldns\_rr\_rd\_count*() returns the rd\_count of an rr structure.  
**\*rr**: the rr to read from  
Returns the rd count of the rr

*ldns\_rr\_ttl*() returns the ttl of an rr structure.  
**\*rr**: the rr to read from  
Returns the ttl of the rr

*ldns\_rr\_get\_class*() returns the class of the rr.  
**\*rr**: the rr to read from  
Returns the class of the rr

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_rd_count(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
