ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_set\_owner, ldns\_rr\_set\_ttl, ldns\_rr\_set\_type, ldns\_rr\_set\_rd\_count, ldns\_rr\_set\_class, ldns\_rr\_set\_rdf - set ldns\_rr attributes

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

void ldns\_rr\_set\_owner(ldns\_rr \*rr, ldns\_rdf \*owner);

void ldns\_rr\_set\_ttl(ldns\_rr \*rr, uint32\_t ttl);

void ldns\_rr\_set\_type(ldns\_rr \*rr, ldns\_rr\_type rr\_type);

void ldns\_rr\_set\_rd\_count(ldns\_rr \*rr, size\_t count);

void ldns\_rr\_set\_class(ldns\_rr \*rr, ldns\_rr\_class rr\_class);

ldns\_rdf* ldns\_rr\_set\_rdf(ldns\_rr \*rr, const ldns\_rdf \*f, size\_t position);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_set\_owner*() sets the owner in the rr structure.  
**\*rr**: rr to operate on  
**\*owner**: set to this owner  
Returns void

*ldns\_rr\_set\_ttl*() sets the ttl in the rr structure.  
**\*rr**: rr to operate on  
**ttl**: set to this ttl  
Returns void

*ldns\_rr\_set\_type*() sets the type in the rr.  
**\*rr**: rr to operate on  
**rr\_type**: set to this type  
Returns void

*ldns\_rr\_set\_rd\_count*() sets the rd\_count in the rr.  
**\*rr**: rr to operate on  
**count**: set to this count  
Returns void

*ldns\_rr\_set\_class*() sets the class in the rr.  
**\*rr**: rr to operate on  
**rr\_class**: set to this class  
Returns void

*ldns\_rr\_set\_rdf*() sets a rdf member, it will be set on the position given. The old value is returned, like pop.  
**\*rr**: the rr to operate on  
**\*f**: the rdf to set  
**position**: the position the set the rdf  
Returns the old value in the rr, NULL on failure

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_set_type(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
