ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_update\_pkt\_new - create an update packet

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_pkt* ldns\_update\_pkt\_new(ldns\_rdf \*zone\_rdf, ldns\_rr\_class clas, const ldns\_rr\_list \*pr\_rrlist, const ldns\_rr\_list \*up\_rrlist, const ldns\_rr\_list \*ad\_rrlist);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_update\_pkt\_new*() create an update packet from zone name, class and the rr lists  
**zone\_rdf**: name of the zone The returned packet will take ownership of zone\_rdf, so the caller should not free it  
**clas**: zone class  
**pr\_rrlist**: list of Prerequisite Section RRs  
**up\_rrlist**: list of Updates Section RRs  
**ad\_rrlist**: list of Additional Data Section RRs (currently unused)  
Returns the new packet

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_update\_pkt\_tsig\_add*, *ldns\_update\_pkt\_tsig\_add*, *ldns\_update\_zocount*, *ldns\_update\_prcount*, *ldns\_update\_upcount*, *ldns\_update\_adcount*, *ldns\_update\_set\_zocount*, *ldns\_update\_set\_prcount*, *ldns\_update\_set\_upcount*, *ldns\_update\_set\_adcount*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_update_pkt_new(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
