ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_update\_zocount, ldns\_update\_prcount, ldns\_update\_upcount, ldns\_update\_adcount - return update packet counters

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

uint16\_t ldns\_update\_zocount(const ldns\_pkt \*p);

uint16\_t ldns\_update\_prcount(const ldns\_pkt \*p);

uint16\_t ldns\_update\_upcount(const ldns\_pkt \*p);

ldns\_update\_adcount();

# [DESCRIPTION](#DESCRIPTION)

*ldns\_update\_zocount*() Get the zo count  
**p**: the packet  
Returns the zo count

*ldns\_update\_prcount*() Get the zo count  
**p**: the packet  
Returns the pr count

*ldns\_update\_upcount*() Get the zo count  
**p**: the packet  
Returns the up count

*ldns\_update\_adcount*()

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_update\_pkt\_new*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_update_prcount(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
