ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_verify, ldns\_verify\_rrsig, ldns\_verify\_rrsig\_keylist, ldns\_verify\_rrsig\_keylist\_notime, ldns\_verify\_notime - verify rrsigs

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_verify(ldns\_rr\_list \*rrset, ldns\_rr\_list \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

ldns\_status ldns\_verify\_rrsig(ldns\_rr\_list \*rrset, ldns\_rr \*rrsig, ldns\_rr \*key);

ldns\_status ldns\_verify\_rrsig\_keylist(ldns\_rr\_list \*rrset, ldns\_rr \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

ldns\_status ldns\_verify\_rrsig\_keylist\_notime(const ldns\_rr\_list \*rrset, const ldns\_rr \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

ldns\_status ldns\_verify\_notime(ldns\_rr\_list \*rrset, ldns\_rr\_list \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_verify*() Verifies a list of signatures for one rrset.

**rrset**: the rrset to verify  
**rrsig**: a list of signatures to check  
**keys**: a list of keys to check with  
**good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it  
Returns status LDNS\_STATUS\_OK if there is at least one correct key

*ldns\_verify\_rrsig*() verify an rrsig with 1 key  
**rrset**: the rrset  
**rrsig**: the rrsig to verify  
**key**: the key to use  
Returns status message whether verification succeeded.

*ldns\_verify\_rrsig\_keylist*() Verifies an rrsig. All keys in the keyset are tried.  
**rrset**: the rrset to check  
**rrsig**: the signature of the rrset  
**keys**: the keys to try  
**good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it  
Returns a list of keys which validate the rrsig + rrset. Returns status LDNS\_STATUS\_OK if at least one key matched. Else an error.

*ldns\_verify\_rrsig\_keylist\_notime*() Verifies an rrsig. All keys in the keyset are tried. Time is not checked.  
**rrset**: the rrset to check  
**rrsig**: the signature of the rrset  
**keys**: the keys to try  
**good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it  
Returns a list of keys which validate the rrsig + rrset. Returns status LDNS\_STATUS\_OK if at least one key matched. Else an error.

*ldns\_verify\_notime*() Verifies a list of signatures for one rrset, but disregard the time. Inception and Expiration are not checked.

**rrset**: the rrset to verify  
**rrsig**: a list of signatures to check  
**keys**: a list of keys to check with  
**good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it  
Returns status LDNS\_STATUS\_OK if there is at least one correct key

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_verify\_rrsig\_evp*, *ldns\_verify\_rrsig\_dsa*, *ldns\_verify\_rrsig\_rsasha1*, *ldns\_verify\_rrsig\_rsamd5*, *ldns\_sign\_public*, *ldns\_zone\_sign*, *ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_verify_rrsig_keylist(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
