ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_zone\_sort, ldns\_zone\_glue\_rr\_list - sort a zone and get the glue records

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

void ldns\_zone\_sort(ldns\_zone \*zone);

ldns\_rr\_list* ldns\_zone\_glue\_rr\_list(const ldns\_zone \*z);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_zone\_sort*() Sort the rrs in a zone, with the current impl. this is slow  
**zone**: the zone to sort

*ldns\_zone\_glue\_rr\_list*() Retrieve all resource records from the zone that are glue records. The resulting list does are pointer references to the zone's data.

Due to the current zone implementation (as a list of rr's), this function is extremely slow. Another (probably better) way to do this is to use an ldns\_dnssec\_zone structure and the ldns\_dnssec\_mark\_and\_get\_glue() function.

**z**: the zone to look for glue  
Returns the rr\_list with the glue

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_zone_glue_rr_list(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
