ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_zone\_push\_rr, ldns\_zone\_push\_rr\_list - add rr's to a ldns\_zone

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

bool ldns\_zone\_push\_rr(ldns\_zone \*z, ldns\_rr \*rr);

bool ldns\_zone\_push\_rr\_list(ldns\_zone \*z, const ldns\_rr\_list \*list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_zone\_push\_rr*() push an single rr to a zone structure. This function use pointer copying, so the rr\_list structure inside z is modified!  
**z**: the zone to add to  
**rr**: the rr to add  
Returns a true on success otherwise false

*ldns\_zone\_push\_rr\_list*() push an rrlist to a zone structure. This function use pointer copying, so the rr\_list structure inside z is modified!  
**z**: the zone to add to  
**list**: the list to add  
Returns a true on success otherwise false

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_zone_push_rr_list(3) from ldns 1.9.2-r2 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
