ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_bget\_token, ldns\_bgetc, ldns\_bskipcs - get tokens from buffers

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ssize\_t ldns\_bget\_token(ldns\_buffer \*b, char \*token, const char \*delim, size\_t limit);

int ldns\_bgetc(ldns\_buffer \*buffer);

void ldns\_bskipcs(ldns\_buffer \*buffer, const char \*s);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_bget\_token*() returns a token/char from the buffer b. This function deals with ( and ) in the buffer, and ignores when it finds them.  
**\*b**: the buffer to read from  
**\*token**: the token is put here  
**\*delim**: chars at which the parsing should stop  
**\*limit**: how much to read. If 0 the builtin maximum is used  
Returns s 0 on error of EOF of b. Otherwise return the length of what is read

*ldns\_bgetc*() returns the next character from a buffer. Advances the position pointer with 1. When end of buffer is reached returns EOF. This is the buffer's equivalent for getc().  
**\*buffer**: buffer to read from  
Returns EOF on failure otherwise return the character

*ldns\_bskipcs*() skips all of the characters in the given string in the buffer, moving the position to the first character that is not in \*s.  
**\*buffer**: buffer to use  
**\*s**: characters to skip  
Returns void

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_bget_token(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
