ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_buffer2pkt\_wire - convert buffer/wire format to ldns\_pkt

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_buffer2pkt\_wire(ldns\_pkt \*\*packet, const ldns\_buffer \*buffer);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_buffer2pkt\_wire*() converts the data in the ldns\_buffer (in wire format) to a DNS packet. This function will initialize and allocate memory space for the packet structure.

**packet**: pointer to the structure to hold the packet  
**buffer**: the buffer with the data  
Returns LDNS\_STATUS\_OK if everything succeeds, error otherwise

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_buffer2pkt_wire(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
