ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_buffer\_remaining\_at, ldns\_buffer\_remaining, ldns\_buffer\_available\_at, ldns\_buffer\_available, ldns\_buffer\_status, ldns\_buffer\_status\_ok - check buffer status

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

size\_t ldns\_buffer\_remaining\_at(const ldns\_buffer \*buffer, size\_t at);

size\_t ldns\_buffer\_remaining(const ldns\_buffer \*buffer);

int ldns\_buffer\_available\_at(const ldns\_buffer \*buffer, size\_t at, size\_t count);

int ldns\_buffer\_available(const ldns\_buffer \*buffer, size\_t count);

ldns\_status ldns\_buffer\_status(const ldns\_buffer \*buffer);

bool ldns\_buffer\_status\_ok(const ldns\_buffer \*buffer);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_buffer\_remaining\_at*() returns the number of bytes remaining between the indicated position and the limit.  
**buffer**: the buffer  
**at**: indicated position  
Returns number of bytes

*ldns\_buffer\_remaining*() returns the number of bytes remaining between the buffer's position and limit.  
**buffer**: the buffer  
Returns the number of bytes

*ldns\_buffer\_available\_at*() checks if the buffer has at least COUNT more bytes available. Before reading or writing the caller needs to ensure enough space is available!  
**buffer**: the buffer  
**at**: indicated position  
**count**: how much is available  
Returns true or false (as int?)

*ldns\_buffer\_available*() checks if the buffer has count bytes available at the current position  
**buffer**: the buffer  
**count**: how much is available  
Returns true or false (as int?)

*ldns\_buffer\_status*() returns the status of the buffer \\param\[in] buffer  
Returns the status

*ldns\_buffer\_status\_ok*() returns true if the status of the buffer is LDNS\_STATUS\_OK, false otherwise  
**buffer**: the buffer  
Returns true or false

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_buffer*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_buffer_status(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
