ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_calc\_keytag, ldns\_calc\_keytag\_raw - calculate ldns keytag

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

uint16\_t ldns\_calc\_keytag(const ldns\_rr \*key);

uint16\_t ldns\_calc\_keytag\_raw(const uint8\_t* key, size\_t keysize);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_calc\_keytag*() calculates a keytag of a key for use in DNSSEC.

**key**: the key as an RR to use for the calc.  
Returns the keytag

*ldns\_calc\_keytag\_raw*() Calculates keytag of DNSSEC key, operates on wireformat rdata.  
**key**: the key as uncompressed wireformat rdata.  
**keysize**: length of key data.  
Returns the keytag

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_calc_keytag_raw(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
