ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dname\_left\_chop, ldns\_dname\_label\_count - dname label functions

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rdf* ldns\_dname\_left\_chop(const ldns\_rdf \*d);

uint8\_t ldns\_dname\_label\_count(const ldns\_rdf \*r);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dname\_left\_chop*() chop one label off the left side of a dname. so wwww.nlnetlabs.nl, becomes nlnetlabs.nl This new name is a clone and must be freed with ldns\_deep\_free()  
**d**: the dname to chop  
Returns the remaining dname

*ldns\_dname\_label\_count*() count the number of labels inside a LDNS\_RDF\_DNAME type rdf.  
**\*r**: the rdf  
Returns the number of labels

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dname_label_count(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
