ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dnssec\_data\_chain\_new, ldns\_dnssec\_data\_chain\_free, ldns\_dnssec\_data\_chain\_deep\_free, ldns\_dnssec\_build\_data\_chain, ldns\_dnssec\_data\_chain\_print - ldns\_chain creation, destruction and printing

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_dnssec\_data\_chain* ldns\_dnssec\_data\_chain\_new(void);

void ldns\_dnssec\_data\_chain\_free(ldns\_dnssec\_data\_chain \*chain);

void ldns\_dnssec\_data\_chain\_deep\_free(ldns\_dnssec\_data\_chain \*chain);

ldns\_dnssec\_data\_chain* ldns\_dnssec\_build\_data\_chain(ldns\_resolver \*res, const uint16\_t qflags, const ldns\_rr\_list \*data\_set, const ldns\_pkt \*pkt, ldns\_rr \*orig\_rr);

void ldns\_dnssec\_data\_chain\_print(FILE \*out, const ldns\_dnssec\_data\_chain \*chain);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dnssec\_data\_chain\_new*() Creates a new dnssec\_chain structure  
Returns ldns\_dnssec\_data\_chain *

*ldns\_dnssec\_data\_chain\_free*() Frees a dnssec\_data\_chain structure

**\*chain**: The chain to free

*ldns\_dnssec\_data\_chain\_deep\_free*() Frees a dnssec\_data\_chain structure, and all data contained therein

**\*chain**: The dnssec\_data\_chain to free

*ldns\_dnssec\_build\_data\_chain*() Build an ldns\_dnssec\_data\_chain, which contains all DNSSEC data that is needed to derive the trust tree later

The data\_set will be cloned

**\*res**: resolver structure for further needed queries  
**qflags**: resolution flags  
**\*data\_set**: The original rrset where the chain ends  
**\*pkt**: optional, can contain the original packet (and hence the sigs and maybe the key)  
**\*orig\_rr**: The original Resource Record

Returns the DNSSEC data chain

*ldns\_dnssec\_data\_chain\_print*() Prints the dnssec\_data\_chain to the given file stream

**\*out**: The file stream to print to  
**\*chain**: The dnssec\_data\_chain to print

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_dnssec\_data\_chain*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dnssec_data_chain_print(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
