ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dnssec\_rrsets\_new, ldns\_dnssec\_rrsets\_free, ldns\_dnssec\_rrsets\_type, ldns\_dnssec\_rrsets\_set\_type, ldns\_dnssec\_rrsets\_add\_rr, ldns\_dnssec\_rrsets\_print - functions for ldns\_dnssec\_rrsets

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_dnssec\_rrsets* ldns\_dnssec\_rrsets\_new(void);

void ldns\_dnssec\_rrsets\_free(ldns\_dnssec\_rrsets \*rrsets);

ldns\_rr\_type ldns\_dnssec\_rrsets\_type(const ldns\_dnssec\_rrsets \*rrsets);

ldns\_status ldns\_dnssec\_rrsets\_set\_type(ldns\_dnssec\_rrsets \*rrsets, ldns\_rr\_type type);

ldns\_status ldns\_dnssec\_rrsets\_add\_rr(ldns\_dnssec\_rrsets \*rrsets, ldns\_rr \*rr);

void ldns\_dnssec\_rrsets\_print(FILE \*out, const ldns\_dnssec\_rrsets \*rrsets, bool follow);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dnssec\_rrsets\_new*() Creates a new list (entry) of RRsets  
Returns the newly allocated structure

*ldns\_dnssec\_rrsets\_free*() Frees the list of rrsets and their rrs, but \*not* the ldns\_rr records in the sets

**rrsets**: the data structure to free

*ldns\_dnssec\_rrsets\_type*() Returns the rr type of the rrset (that is head of the given list)

**rrsets**: the rrset to get the type of  
Returns the rr type

*ldns\_dnssec\_rrsets\_set\_type*() Sets the RR type of the rrset (that is head of the given list)

**rrsets**: the rrset to set the type of  
**type**: the type to set  
Returns LDNS\_STATUS\_OK on success

*ldns\_dnssec\_rrsets\_add\_rr*() Add an ldns\_rr to the corresponding RRset in the given list of RRsets. If it is not present, add it as a new RRset with 1 record.

**rrsets**: the list of rrsets to add the RR to  
**rr**: the rr to add to the list of rrsets  
Returns LDNS\_STATUS\_OK on success and LDNS\_STATUS\_EQUAL\_ERR when and RR with equal ownername, class, type and rdata already exists.

*ldns\_dnssec\_rrsets\_print*() Print the given list of rrsets to the given file descriptor

**out**: the file descriptor to print to  
**rrsets**: the list of RRsets to print  
**follow**: if set to false, only print the first RRset

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_dnssec\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dnssec_rrsets_free(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
