ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dnssec\_verify\_denial, ldns\_dnssec\_verify\_denial\_nsec3 - verify denial of existence

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_dnssec\_verify\_denial(ldns\_rr \*rr, ldns\_rr\_list \*nsecs, ldns\_rr\_list \*rrsigs);

ldns\_status ldns\_dnssec\_verify\_denial\_nsec3(ldns\_rr \*rr, ldns\_rr\_list \*nsecs, ldns\_rr\_list \*rrsigs, ldns\_pkt\_rcode packet\_rcode, ldns\_rr\_type packet\_qtype, bool packet\_nodata);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dnssec\_verify\_denial*() denial is not just a river in egypt

**rr**: The (query) RR to check the denial of existence for  
**nsecs**: The list of NSEC RRs that are supposed to deny the existence of the RR  
**rrsigs**: The RRSIG RR covering the NSEC RRs  
Returns LDNS\_STATUS\_OK if the NSEC RRs deny the existence, error code containing the reason they do not otherwise

*ldns\_dnssec\_verify\_denial\_nsec3*() Denial of existence using NSEC3 records Since NSEC3 is a bit more complicated than normal denial, some context arguments are needed

**rr**: The (query) RR to check the denial of existence for  
**nsecs**: The list of NSEC3 RRs that are supposed to deny the existence of the RR  
**rrsigs**: The RRSIG rr covering the NSEC RRs  
**packet\_rcode**: The RCODE value of the packet that provided the NSEC3 RRs  
**packet\_qtype**: The original query RR type  
**packet\_nodata**: True if the providing packet had an empty ANSWER section  
Returns LDNS\_STATUS\_OK if the NSEC3 RRs deny the existence, error code containing the reason they do not otherwise

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_dnssec\_trust\_tree*, *ldns\_dnssec\_data\_chain*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dnssec_verify_denial_nsec3(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
