ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_dnssec\_zone, ldns\_dnssec\_name, ldns\_dnssec\_rrs, ldns\_dnssec\_rrsets - data structures

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_dnssec\_zone();

# [DESCRIPTION](#DESCRIPTION)

*ldns\_dnssec\_zone*()

*ldns\_dnssec\_name*  
Structure containing all resource records for a domain name  
Including the derived NSEC3, if present  
struct ldns\_struct\_dnssec\_name  
{  
/\**  
\* pointer to a dname containing the name.  
\* Usually points to the owner name of the first RR of the first RRset  
\*/  
ldns\_rdf \*name;  
/\**  
\* Usually, the name is a pointer to the owner name of the first rr for  
\* this name, but sometimes there is no actual data to point to,  
\* for instance in  
\* names representing empty nonterminals. If so, set name\_alloced to true to  
\* indicate that this data must also be freed when the name is freed  
\*/  
bool name\_alloced;  
/\**  
\* The rrsets for this name  
\*/  
ldns\_dnssec\_rrsets \*rrsets;  
/\**  
\* NSEC pointing to the next name (or NSEC3 pointing to the next NSEC3)  
\*/  
ldns\_rr \*nsec;  
/\**  
\* signatures for the NSEC record  
\*/  
ldns\_dnssec\_rrs \*nsec\_signatures;  
/\**  
\* Unlike what the name is\_glue suggests, this field is set to true by  
\* ldns\_dnssec\_zone\_mark\_glue() or ldns\_dnssec\_zone\_mark\_and\_get\_glue()  
\* when the name, this dnssec\_name struct represents, is occluded.  
\* Names that contain other occluded rrsets and records with glue on  
\* the delegation point will NOT have this bool set to true.  
\* This field should NOT be read directly, but only via the  
\* ldns\_dnssec\_name\_is\_glue() function!  
\*/  
bool is\_glue;  
/\**  
\* pointer to store the hashed name (only used when in an NSEC3 zone  
\*/  
ldns\_rdf \*hashed\_name;  
};

typedef struct ldns\_struct\_dnssec\_name ldns\_dnssec\_name;

*ldns\_dnssec\_rrs*  
Singly linked list of rrs  
struct ldns\_struct\_dnssec\_rrs  
{  
ldns\_rr \*rr;  
ldns\_dnssec\_rrs \*next;  
};

typedef struct ldns\_struct\_dnssec\_rrs ldns\_dnssec\_rrs;

*ldns\_dnssec\_rrsets*  
Singly linked list of RRsets  
struct ldns\_struct\_dnssec\_rrsets  
{  
ldns\_dnssec\_rrs \*rrs;  
ldns\_rr\_type type;  
ldns\_dnssec\_rrs \*signatures;  
ldns\_dnssec\_rrsets \*next;  
};

typedef struct ldns\_struct\_dnssec\_rrsets ldns\_dnssec\_rrsets;

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_dnssec\_zone\_new*, *ldns\_dnssec\_name\_new*, *ldns\_dnssec\_rrs\_new*, *ldns\_dnssec\_rrsets\_new*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_dnssec_zone(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
