ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_getaddrinfo - mimic libc getaddrinfo

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

uint16\_t ldns\_getaddrinfo(ldns\_resolver \*res, const ldns\_rdf \*node, ldns\_rr\_class c, ldns\_rr\_list \*\*list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_getaddrinfo*() This function is a wrapper function for ldns\_get\_rr\_list\_name\_by\_addr and ldns\_get\_rr\_list\_addr\_by\_name. It's name is from the getaddrinfo() library call. It tries to mimic that call, but without the lowlevel stuff.  
**res**: The resolver. If this value is NULL then a resolver will be created by ldns\_getaddrinfo.  
**node**: the name or ip address to look up  
**c**: the class to look in  
**list**: put the found RR's in this list  
Returns the number of RR found.

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_getaddrinfo(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
