ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_key\_buf2dsa, ldns\_key\_buf2rsa - convert buffer to openssl key

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

DSA* ldns\_key\_buf2dsa(const ldns\_buffer \*key);

RSA* ldns\_key\_buf2rsa(const ldns\_buffer \*key);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_key\_buf2dsa*() converts a buffer holding key material to a DSA key in openssl.

**key**: the key to convert  
Returns a DSA * structure with the key material

*ldns\_key\_buf2rsa*() converts a buffer holding key material to a RSA key in openssl.

**key**: the key to convert  
Returns a RSA * structure with the key material

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key\_rr2ds*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_key_buf2rsa(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
