ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_key\_list\_key\_count, ldns\_key\_list\_key, ldns\_key\_rsa\_key, ldns\_key\_dsa\_key, ldns\_key\_algorithm, ldns\_key\_hmac\_key, ldns\_key\_origttl, ldns\_key\_inception, ldns\_key\_expiration, ldns\_key\_keytag, ldns\_key\_pubkey\_owner, ldns\_key\_flags - read ldns\_keys

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

size\_t ldns\_key\_list\_key\_count(const ldns\_key\_list \*key\_list);

ldns\_key* ldns\_key\_list\_key(const ldns\_key\_list \*key, size\_t nr);

RSA* ldns\_key\_rsa\_key(const ldns\_key \*k);

DSA* ldns\_key\_dsa\_key(const ldns\_key \*k);

ldns\_signing\_algorithm ldns\_key\_algorithm(const ldns\_key \*k);

unsigned char* ldns\_key\_hmac\_key(const ldns\_key \*k);

uint32\_t ldns\_key\_origttl(const ldns\_key \*k);

uint32\_t ldns\_key\_inception(const ldns\_key \*k);

uint32\_t ldns\_key\_expiration(const ldns\_key \*k);

uint16\_t ldns\_key\_keytag(const ldns\_key \*k);

ldns\_rdf* ldns\_key\_pubkey\_owner(const ldns\_key \*k);

uint16\_t ldns\_key\_flags(const ldns\_key \*k);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_key\_list\_key\_count*() returns the number of keys in the key list  
**key\_list**: the key\_list  
Returns the numbers of keys in the list

*ldns\_key\_list\_key*() returns a pointer to the key in the list at the given position  
**key**: the key  
**nr**: the position in the list  
Returns the key

*ldns\_key\_rsa\_key*() returns the (openssl) RSA struct contained in the key  
**k**: the key to look in  
Returns the RSA * structure in the key

*ldns\_key\_dsa\_key*() returns the (openssl) DSA struct contained in the key

*ldns\_key\_algorithm*() return the signing alg of the key  
**k**: the key  
Returns the algorithm

*ldns\_key\_hmac\_key*() return the hmac key data  
**k**: the key  
Returns the hmac key data

*ldns\_key\_origttl*() return the original ttl of the key  
**k**: the key  
Returns the original ttl

*ldns\_key\_inception*() return the key's inception date  
**k**: the key  
Returns the inception date

*ldns\_key\_expiration*() return the key's expiration date  
**k**: the key  
Returns the expiration date

*ldns\_key\_keytag*() return the keytag  
**k**: the key  
Returns the keytag

*ldns\_key\_pubkey\_owner*() return the public key's owner  
**k**: the key  
Returns the owner

*ldns\_key\_flags*() return the flag of the key  
**k**: the key  
Returns the flag

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_key_list_key(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
