ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr2wire, ldns\_pkt2wire, ldns\_rdf2wire - conversion functions

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_rr2wire(uint8\_t \*\*dest, const ldns\_rr \*rr, int section, size\_t \*size);

ldns\_status ldns\_pkt2wire(uint8\_t \*\*dest, const ldns\_pkt \*p, size\_t \*size);

ldns\_status ldns\_rdf2wire(uint8\_t \*\*dest, const ldns\_rdf \*rdf, size\_t \*size);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr2wire*() Allocates an array of uint8\_t at dest, and puts the wireformat of the given rr in that array. The result\_size value contains the length of the array, if it succeeds, and 0 otherwise (in which case the function also returns NULL)

If the section argument is LDNS\_SECTION\_QUESTION, data like ttl and rdata are not put into the result

**dest**: pointer to the array of bytes to be created  
**rr**: the rr to convert  
**section**: the rr section, determines how the rr is written.  
**size**: the size of the converted result

*ldns\_pkt2wire*() Allocates an array of uint8\_t at dest, and puts the wireformat of the given packet in that array. The result\_size value contains the length of the array, if it succeeds, and 0 otherwise (in which case the function also returns NULL)

**dest**: pointer to the array of bytes to be created  
**p**: the packet to convert  
**size**: the size of the converted result

*ldns\_rdf2wire*() Allocates an array of uint8\_t at dest, and puts the wireformat of the given rdf in that array. The result\_size value contains the length of the array, if it succeeds, and 0 otherwise (in which case the function also returns NULL)

**dest**: pointer to the array of bytes to be created  
**rdf**: the rdata field to convert  
**size**: the size of the converted result

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_wire2rr*, *ldns\_wire2pkt*, *ldns\_wire2rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rdf2wire(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
