ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rdf\_address\_reverse - reverse an address rdf

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rdf* ldns\_rdf\_address\_reverse(const ldns\_rdf \*rd);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rdf\_address\_reverse*() reverses an rdf, only actually useful for AAAA and A records. The returned rdf has the type LDNS\_RDF\_TYPE\_DNAME!  
**\*rd**: rdf to be reversed  
Returns the reversed rdf (a newly created rdf)

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rdf_address_reverse(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
