ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rdf\_set\_size, ldns\_rdf\_set\_type, ldns\_rdf\_set\_data - set rdf attributes

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

void ldns\_rdf\_set\_size(ldns\_rdf \*rd, size\_t size);

void ldns\_rdf\_set\_type(ldns\_rdf \*rd, ldns\_rdf\_type type);

void ldns\_rdf\_set\_data(ldns\_rdf \*rd, void \*data);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rdf\_set\_size*() sets the size of the rdf.  
**\*rd**: the rdf to operate on  
**size**: the new size  
Returns void

*ldns\_rdf\_set\_type*() sets the size of the rdf.  
**\*rd**: the rdf to operate on  
**type**: the new type  
Returns void

*ldns\_rdf\_set\_data*() sets the size of the rdf.  
**\*rd**: the rdf to operate on  
**\*data**: pointer to the new data  
Returns void

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rdf_set_type(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
