ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_compare, ldns\_rr\_compare\_ds - compare a ldns\_rr

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

int ldns\_rr\_compare(const ldns\_rr \*rr1, const ldns\_rr \*rr2);

bool ldns\_rr\_compare\_ds(const ldns\_rr \*rr1, const ldns\_rr \*rr2);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_compare*() compares two rrs. The TTL is not looked at.  
**rr1**: the first one  
**rr2**: the second one  
Returns 0 if equal -1 if rr1 comes before rr2 +1 if rr2 comes before rr1

*ldns\_rr\_compare\_ds*() returns true of the given rr's are equal. Also returns true if one record is a DS that represents the same DNSKEY record as the other record  
**rr1**: the first rr  
**rr2**: the second rr  
Returns true if equal otherwise false

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_compare_ds(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
