ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_push\_rdf, ldns\_rr\_pop\_rdf - push and pop rdata fields

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

bool ldns\_rr\_push\_rdf(ldns\_rr \*rr, const ldns\_rdf \*f);

ldns\_rdf* ldns\_rr\_pop\_rdf(ldns\_rr \*rr);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_push\_rdf*() sets rd\_field member, it will be placed in the next available spot.  
**\*rr**: rr to operate on  
**\*f**: the data field member to set  
Returns bool

*ldns\_rr\_pop\_rdf*() removes a rd\_field member, it will be popped from the last position.  
**\*rr**: rr to operate on  
Returns rdf which was popped (null if nothing)

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_push_rdf(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
