ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_rr\_set\_push\_rr, ldns\_rr\_set\_pop\_rr - push and pop rr on a rrset

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

bool ldns\_rr\_set\_push\_rr(ldns\_rr\_list \*rr\_list, ldns\_rr \*rr);

ldns\_rr* ldns\_rr\_set\_pop\_rr(ldns\_rr\_list \*rr\_list);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_rr\_set\_push\_rr*() pushes an rr to an rrset (which really are rr\_list's).  
**\*rr\_list**: the rrset to push the rr to  
**\*rr**: the rr to push  
Returns true if the push succeeded otherwise false

*ldns\_rr\_set\_pop\_rr*() pops the last rr from an rrset. This function is there only for the symmetry.  
**rr\_list**: the rr\_list to pop from  
Returns NULL if nothing to pop. Otherwise the popped RR

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_rr_set_pop_rr(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
