ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_sign\_public - sign an rrset

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rr\_list* ldns\_sign\_public(ldns\_rr\_list \*rrset, ldns\_key\_list \*keys);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_sign\_public*() Sign an rrset  
**rrset**: the rrset  
**keys**: the keys to use  
Returns a rr\_list with the signatures

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_sign\_public\_dsa*, *ldns\_sign\_public\_rsamd5*, *ldns\_sign\_public\_rsasha1*, *ldns\_verify*, *ldns\_verify\_rrsig*, *ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_sign_public(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
