ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_sign\_public\_dsa, ldns\_sign\_public\_rsamd5, ldns\_sign\_public\_rsasha1 - sign buffer

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_rdf* ldns\_sign\_public\_dsa(ldns\_buffer \*to\_sign, DSA \*key);

ldns\_rdf* ldns\_sign\_public\_rsamd5(ldns\_buffer \*to\_sign, RSA \*key);

ldns\_rdf* ldns\_sign\_public\_rsasha1(ldns\_buffer \*to\_sign, RSA \*key);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_sign\_public\_dsa*() Sign a buffer with the DSA key (hash with SHA1)

**to\_sign**: The ldns\_buffer containing raw data that is to be signed  
**key**: The DSA key structure to sign with  
Returns a ldns\_rdf for the RRSIG ldns\_rr

*ldns\_sign\_public\_rsamd5*() Sign a buffer with the RSA key (hash with MD5)  
**to\_sign**: buffer with the data  
**key**: the key to use  
Returns a ldns\_rdf with the signed data

*ldns\_sign\_public\_rsasha1*() Sign a buffer with the RSA key (hash with SHA1)  
**to\_sign**: buffer with the data  
**key**: the key to use  
Returns a ldns\_rdf with the signed data

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_sign\_public*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_sign_public_dsa(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
