ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_update\_pkt\_tsig\_add - add resolver's tsig credentials to an ldns\_pkt

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_update\_pkt\_tsig\_add(ldns\_pkt \*p, const ldns\_resolver \*r);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_update\_pkt\_tsig\_add*() add tsig credentials to a packet from a resolver  
**p**: packet to copy to  
**r**: resolver to copy from

Returns status whether successful or not

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_update\_pkt\_new*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_update_pkt_tsig_add(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
