ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_update\_set\_zocount, ldns\_update\_set\_prcount, ldns\_update\_set\_upcount, ldns\_update\_set\_adcount - set the update packet counters

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_update\_set\_zocount();

void ldns\_update\_set\_prcount(ldns\_pkt \*p, uint16\_t c);

void ldns\_update\_set\_upcount(ldns\_pkt \*p, uint16\_t c);

void ldns\_update\_set\_adcount(ldns\_pkt \*p, uint16\_t c);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_update\_set\_zocount*()

*ldns\_update\_set\_prcount*() Set the pr count  
**p**: the packet  
**c**: the pr count to set

*ldns\_update\_set\_upcount*() Set the up count  
**p**: the packet  
**c**: the up count to set

*ldns\_update\_set\_adcount*() Set the ad count  
**p**: the packet  
**c**: the ad count to set

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_update\_pkt\_new*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_update_set_zocount(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
