ldns(3) Library Functions Manual ldns(3)

# [NAME](#NAME)

ldns\_verify\_rrsig\_dsa, ldns\_verify\_rrsig\_rsasha1, ldns\_verify\_rrsig\_rsamd5 - verify signature data buffers

# [SYNOPSIS](#SYNOPSIS)

#include &lt;stdint.h&gt;  
#include &lt;stdbool.h&gt;

#include &lt;ldns/ldns.h&gt;

ldns\_status ldns\_verify\_rrsig\_dsa(ldns\_buffer \*sig, ldns\_buffer \*rrset, ldns\_buffer \*key);

ldns\_status ldns\_verify\_rrsig\_rsasha1(ldns\_buffer \*sig, ldns\_buffer \*rrset, ldns\_buffer \*key);

ldns\_status ldns\_verify\_rrsig\_rsamd5(ldns\_buffer \*sig, ldns\_buffer \*rrset, ldns\_buffer \*key);

# [DESCRIPTION](#DESCRIPTION)

*ldns\_verify\_rrsig\_dsa*() verifies a buffer with signature data (DSA) for a buffer with rrset data with a buffer with key data.

**sig**: the signature data  
**rrset**: the rrset data, sorted and processed for verification  
**key**: the key data

*ldns\_verify\_rrsig\_rsasha1*() verifies a buffer with signature data (RSASHA1) for a buffer with rrset data with a buffer with key data.

**sig**: the signature data  
**rrset**: the rrset data, sorted and processed for verification  
**key**: the key data

*ldns\_verify\_rrsig\_rsamd5*() verifies a buffer with signature data (RSAMD5) for a buffer with rrset data with a buffer with key data.

**sig**: the signature data  
**rrset**: the rrset data, sorted and processed for verification  
**key**: the key data

# [AUTHOR](#AUTHOR)

The ldns team at NLnet Labs.

# [REPORTING BUGS](#REPORTING_BUGS)

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

# [COPYRIGHT](#COPYRIGHT)

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

# [SEE ALSO](#SEE_ALSO)

*ldns\_key*, *ldns\_sign\_public*, *ldns\_zone\_sign*, *ldns\_verify*, *ldns\_verify\_rrsig*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

# [REMARKS](#REMARKS)

This manpage was automatically generated from the ldns source code.

30 May 2006

---

Document: ldns_verify_rrsig_rsasha1(3) from ldns 1.9.2-r3 (Chainguard OS)
Source: https://github.com/NLnetLabs/ldns.git
